Tenable.sc Cloud Requirements

Tip: Tenable rebranded SecurityCenter as Tenable.sc. For more information, see the announcement.

You can install Tenable.sc in an Amazon Elastic Compute Cloud (Amazon EC2) cloud-based environment that meets all of the following requirements.

Supported Instance Types

Tenable.sc uses a balance of networking and compute resources and requires persistent storage for proper operation. To meet these requirements, Tenable supports installing Tenable.sc on M5 instances with General Purpose SSD (gp2) EBS storage.

Tenable recommends the following EC2 instance types based on your Tenable.sc deployment size.

Requirements When Running Basic Network Scans + Local Checks

# of Hosts Managed by Tenable.sc EC2 Instance Type Disk Space Used for Vulnerability Trending
1 to 2,500 m5.2xlarge

90 days: 125 GB

180 days: 250 GB

2,501 to 10,000 m5.4xlarge

90 days: 450 GB

180 days: 900 GB

10,001 to 25,000 m5.8xlarge

90 days: 1.2 TB

180 days: 2.4 TB

25,001 to 50,000

m5.12xlarge

90 days: 4.5 TB

180 days: 9 TB

50,001 or more For assistance with large enterprise deployments greater than 50,000 active IP addresses, contact your Tenable representative.

Requirements When Running Basic Network Scans + Local Checks + 1 Configuration Audit

# of Hosts Managed by Tenable.sc EC2 Instance Type Disk Space Used for Vulnerability Trending
1 to 2,500 m5.4xlarge

90 days: 225 GB

180 days: 450 GB

2,501 to 10,000 m5.8xlarge

90 days: 900 GB

180 days: 1.8 TB

10,001 to 25,000 m5.8xlarge

90 days: 2.25 TB

180 days: 4.5 TB

25,001 to 50,000

m5.12xlarge

90 days: 9 TB

180 days: 18 TB

50,001 or more For assistance with large enterprise deployments greater than 50,000 active IP addresses, contact your Tenable representative.

Supported Amazon Machine Images (AMIs)

Tenable does not provide an AMI customized for Tenable.sc. Tenable supports using the following Amazon Marketplace AMI for Tenable.sc:

AMI Required Configuration Changes
CentOS 7 (x86_64) - with Updates HVM
  • This AMI does not include Java, but Tenable.sc requires OpenJDK or the Oracle Java JRE to export PDF reports.

    You must install OpenJDK or the Oracle Java JRE onto your AMI before hosting Tenable.sc. For more information, see Dependencies.

  • This AMI configures an SELinux enforcing mode policy, which requires customization to be compatible with Tenable.sc.

    You must use the SELinux sealert tool to identify errors and solutions. For more information, see Customize SELinux Enforcing Mode Policies for Tenable.sc.

  • You must confirm this AMI meets all other standard requirements for operating systems. For more information, see Operating System Requirements.