Nessus Network Monitor 6.1.0 - Release Notes - 2022-09-20

Note: Standard support for NNM 5.11 ended on 01/21/2022. Tenable recommends updating to NNM 5.13.1 or later. Otherwise, you will not be able to report issues and bugs. Users that connect to Tenable.io using a web proxy need to upgrade to NNM 6.1.0.

Changed Functionality and Performance Enhancements

The following are changed functionality and performance enhancements included in NNM 6.1.0:

  • Support OpenSSL 3.0:
    • NNM 6.1.0 includes security enhancements to support OpenSSL 3.0. The default connection mode of NNM 6.1.0 is TLS 1.2.

  • Support for cloud.tenable.com's new Web Application Firewall (WAF):
    • Supports enhanced security for Tenable.io connections.

  • User interface Security Enhancements.

  • Update NNM's Key to use SHA-2 signing instead of SHA-1.

  • Enhance NNM to send vulnerabilities for the last hour when connecting to Tenable.io for the first time.

For more information about the features and functionality supported in this release, see the Nessus Network Monitor 6.1.x User Guide and the Nessus Network Monitor Deployment Guide.

Release Notes

The following are updates included in NNM 6.1.0:

  • NNM's rpm's are now signed with a 4096 bit signature using SHA256.

  • If you are running NNM in NIAP mode using the default NNM self-signed certificates or if your CA signed certificates are missing the Authority Key Identifier or Subject Key Identifier, OpenSSL 3.0 considers your SSL certificates to be invalid. NNM disables NIAP Mode for these conditions and issue a message in the UI when the user logs on.

  • The latest patches from js.node are included as part of this release.

  • If you connect to Tenable.io using a Web Proxy, you must upgrade to NNM 6.1.0.

Supported Platforms

Support is available for the following platforms:

  • RH7/CentOS7, version 7.9 (64-bit)

  • RH8/CentOS8, versions 8.2-8.5 (64-bit)

  • Microsoft Windows 10 and Windows Server 2012/2016 (all 64-bit)

  • MacOS 10.9-10.13 (64-bit)

Note: This is the final release with support for MacOS 10.9-10.13 (64-bit).