Tenable.ot 3.6.33 Release Notes (2020-07-14)

To download Tenable.ot upgrade files, see: https://tenable-ot.sharefile.com/d-s8ba6342ec004b86a.

For a list of previous versions that are possible to perform a direct upgrade from, see: https://tenable-ot.sharefile.com/d-s10cc31311564736a.

New Features

Vendor Support

  • Premium Support for ABB RTU 540/560

Tenable.io Integration

  • Added integration capabilities to Tenable.io. Integration setup is done with Tenable Support assistance and requires a Tenable.io Access Key, and Secret Key.

Detection of Ripple20 exploit attempts

  • Added an Intrusion Detection rule group which will detect successful identification attempts or exploits of Ripple20 affected assets over the network.

API

  • API Key - API improved to align with the standard Rest API spec. Starting 3.6.33, the API uses the 'X-APIKey' header instead of 'Authorization'

    The new header is: 'X-APIKeys: key= <API_KEY>'

    For example:

    curl -v -k -H 'X-APIKeys: key=Mbvf2sXdROWBrB99MBXwXN-LqYrWVxPEyos1IJk9e9aNPLOlWalkHkAfsS4=' https://IP/v1/status

Bug Fixes

Bug Fix
Grouping Assets by Site fix for Enterprise Manager
Appliance Data Auto-Refresh for Enterprise Manager
Network Summary Widgets Fix of Units & Colors
Traffic and conversation graph on Network Traffic Summary fixed
Filter for empty missing name "Blank" in Exclude from policy
Fix Siprotec4 snapshots conversation delay check
Fix empty data in single vulnerability page
Active Querying RTU 540 failed
Missing the show password option in "Retype New Password" field
Fix save button is enabled when it should not for bulk edit assets
Setup wizard | Split Interface | Fields name are not displayed until clicking on the screen/refresh
Conversation | Duration column filter is not sorted correctly
User unable to copy data from UI
Additional Suricata rules to 3.6 SP
Unicode decoding issue for WMI querying for USB details
ABB RTU 540/560 Premium Support

Integrated Tenable Product Compatibility

The following table lists the Tenable product versions tested with this version of Tenable.ot.

Product Tested Version(s)
Tenable.sc 5.11 and later