TOC & Recently Viewed

Recently Viewed Topics

Before You Upgrade

Note: A basic understanding of Linux is assumed throughout the installation, upgrade, and removal processes.

SecurityCenter Version Requirements

You must be running SecurityCenter 4.8.1.x, 4.8.2.x, or 5.0.0.1 or later in order to upgrade to SecurityCenter5.6.0.

Java Version Requirements

If the Oracle Java JRE or OpenJDK is not installed, the following warning is displayed:

[WARNING] SecurityCenter has determined that Oracle Java JRE and OpenJDK is not installed. One of two must be installed for SecurityCenter reporting to function properly.

You must install the latest version of Oracle Java JRE or OpenJDK to take full advantage of SecurityCenter reporting.

Halt or Complete Running Jobs

Tenable recommends stopping all running SecurityCenter processes before beginning an upgrade. If processes are running (e.g., Nessus scans), the following message is displayed and followed by the related process names and their PIDs:

SecurityCenter has determined that the following jobs are still running. Please wait a few minutes before performing the upgrade again. This will allow the running jobs to complete their tasks.

Stop the processes manually or retry the upgrade after the processes complete.

Backup SecurityCenter Data

Tenable recommends backing up the /opt/sc4 or /opt/sc directory (as appropriate) before beginning the upgrade.

  1. Stop all SecurityCenter processes.
  2. Perform the backup by running the following command from a directory outside of /opt/sc4 or /opt/sc (such as / or /home):

    # tar -pzcf sc_backup.tar.gz /opt/sc4

    # tar -pzcf sc_backup.tar.gz /opt/sc

  3. If the backup leaves too little space to perform the upgrade, move the sc_backup.tar.gz file to a different location.

Rename Mount Point

If the existing /opt/sc4 or /opt/sc directory is or contains a mount point to another location it must be updated. During the rpm upgrade process, a message will be displayed with information about the discovered mount point and instruct you to contact Tenable Support for a mount point tool to help identify and migrate your mount points for the upgrade to continue.

Reconfigure SecurityCenter 5.4 CoSign Authentication

CoSign is not a supported authentication method in SecurityCenter5.6.0. If your SecurityCenter 5.4.x installation uses CoSign servers for authentication, you must reconfigure your SecurityCenter 5.4.x to use an authentication method supported in SecurityCenter5.6.0.

Copyright 2017 Tenable, Inc. All rights reserved. Tenable Network Security, Nessus, SecurityCenter, SecurityCenter Continuous View and Log Correlation Engine are registered trademarks of Tenable, Inc.  Tenable, Tenable.io, Assure, and The Cyber Exposure Company are trademarks of Tenable, Inc.  All other products or services are trademarks of their respective owners.