Browser Requirements

You can access the Tenable.sc user interface using the following browsers:

  • Microsoft Internet Explorer 11 or later
  • Mozilla Firefox 32 or later
  • Google Chrome 37 or later
  • Mac OS Safari 7.1 or later

Note:Tenable recommends using the newest available version of your browser.