Software Requirements

Nessus supports Mac, Linux, and Windows operating systems.

Tip: For information about Tenable Core + Nessus, see System Requirements in the Tenable Core User Guide.

Nessus Scanner, Nessus Manager, and Nessus Professional

For Nessus software requirements, see the Nessus Software Requirements in the General Requirements User Guide.

Nessus Agents

For Nessus Agent software requirements, see the Agent Software Requirements in the General Requirements User Guide.

Supported Browsers

Nessus supports the following browsers:

  • Google Chrome (76+)
  • Apple Safari (10+)
  • Mozilla Firefox (50+)

SELinux Requirements

Nessus supports disabled, permissive, and enforcing mode Security-Enhanced Linux (SELinux) policy configurations.

  • Disabled and permissive mode policies typically do not require customization to interact with Nessus.
  • Enforcing mode policies require customization to interact with Nessus. For more information, see Customize SELinux Enforcing Mode Policies.

Note:Tenable recommends testing your SELinux configurations before deploying on a live network.

PDF Report Requirements

The Nessus .pdf report generation feature requires the latest version of Oracle Java or OpenJDK.

Install Oracle Java or OpenJDK prior to installing Nessus.

Note: If you install Oracle Java or OpenJDK after you install Nessus, you must reinstall Nessus to enable PDF report generation.